Xirgo Inbound Data Processing Delays

Incident Report for GPS Insight

Resolved

This incident has been resolved.
Posted Nov 22, 2025 - 23:34 PST

Monitoring

A fix has been implemented and we are monitoring data flow. We will provide another update once historical data has caught up.
Posted Nov 22, 2025 - 18:51 PST

Investigating

We are experiencing delays in inbound data from Xirgo. You may notice delayed data in dashboards and reports for very recent data. Our team is actively investigating and working to restore service as quickly as possible.
Posted Nov 22, 2025 - 13:58 PST
This incident affected: Alerts, API, Dashboard, Inbound Data, Mobile Apps, and Reports.