Delayed processing of telematics data

Incident Report for GPS Insight

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 12:05 PDT

Monitoring

Delayed device data is recovering.  All Calamp devices should be current. Other device types are still delayed but recovering.  We are working on additional solutions to speed up their recovery.
Posted Mar 25, 2026 - 09:03 PDT

Update

We are experiencing delays in processing inbound data. You may notice delayed data in dashboards and some reports for very recent data. No data is lost, and we will report accurately on historical reports for this time period.
Posted Mar 25, 2026 - 07:29 PDT

Investigating

Our team is currently investigating delays in processing of telematics data
Posted Mar 25, 2026 - 07:18 PDT
This incident affected: Alerts, API, Dashboard, Inbound Data, Mobile Apps, and Reports.